
Example 6. Modelling of Heat Transfer in a Heat Exchanger  

6.1. Introduction and Objectives 

The heat transfer between fluids is one of the most frequently used processes in 

engineering. In the previous example we considered convection by mixing of two water streams 

with different temperature in a T-junction. In engineering practice, the heat transfer is usually 

accomplished by means of a heat exchanger. Common applications of heat exchangers include 

boilers, coolers, and condensers. The most common design of a heat exchanger has two fluid 

streams of different temperature - one of them flowing through metal tubes and the second 

flowing around the tubes. The heat spontaneously flows from a hotter to a colder fluid and is 

transferred from one fluid to the other through the tubes wall by conduction. In this example 

we will consider a single-phase shell-and-tube type heat exchanger that consist of a set of tubes 

closed in a shell. The main objectives of this exercise are as follows: 

 create 3D geometry from 2D drawings located in different sketches, Add Frozen option, 

 generate the mesh with inflation, 

 illustrate the setup of the simulation with heat transfer between two different streams of 

fluid via solid wall, 

 visualization of results – contours of fluid temperature, mean value of temperature at 

the inlets and outflows.  

 

6.2. Problem Description 

Details of the analysed flow problem are shown in Figure E6-1. 

    

Figure E6-1. Problem description.  
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6.3. Geometry 

Geometry in this example will be drawn using primitives and figures that are extruded from 

2D sketches. As you can observe from the problem description we have here the shell that 

contains four tubes inside. Note that the real shell-and-tube heat exchangers have more tubes 

inside. The limitation to four tubes in this example results from the limitation of the student 

version of the software, where simulations can be performed for meshes with a maximum 

number of cells of 512 000 (user is able to generate bigger mesh in Ansys Meshing however it 

cannot be implemented into the Ansys Fluent). The user should be aware that meshes generated 

for real heat exchanger designs can have up to tens of millions of computational cells. 

Comparing to the previous examples, a new feature of this geometry is that three layers of 

the flow domain (cold liquid, solid body and hot liquid) touch each other but they are not 

connected in one body. In contrary, they still are separated bodies. To draw this geometry, we 

have to use three different sketches that are placed in the same plane. Open Ansys 

DesignModeler and go to the Sketching tab. Make sure that Auto Constraints options are 

enabled and setup a proper view by clicking Look At Face/Plane/Sketch.  

Sketch1 

 Draw to circles starting in the origin of the coordinate system. Then measure the diameter 

of these circles and set their values as 0.12 m and. 0.029 m, respectively. In the next step you 

have to draw three circles with diameter of 0.029 that are located symmetrically around the 

centre. In this purpose first select from the 

Draw Toolbox the Polygon with n = 3 and draw 

it starting from the origin and ending at any 

positive point of the X axis. Then, measure the 

distance from the centre to the node of polygon 

and set its value as 0.032 m. Nodes of the 

polygon are centres of the circles, therefore now 

draw three circles starting from the nodes and measure their 

diameter setting the value of 0.029 m (Fig. E6-2a). If during 

dimensioning the red (unnecessary) dimension will appear, close 

the Warning dialog box, click with RMB and select Cancel. In 

the last step select from the sketch (by clicking) lines that form 

the polygon (they will be highlighted by yellow) and remove 

them pressing Delete from the keyboard. The first sketch is ready 

(Fig. E6-2b). Figure E6-2. View of the Sketch1.  



Sketch2 

The second part of the geometry, i.e. the circles that will form the solid body, has to be 

drawn in other sketch. Therefore, a new sketch has to be created first by selecting from the top 

ribbon the New Sketch icon (Fig. E6-3). The 

view of Sketch1 will disturb you, therefore 

go to the Modeling tab, select the Sketch1 

with RMB and choose Hide Sketch option. 

Then select Sketch2 again to make it active 

and come back to the Sketching tab.  

Figure E6-3. Creating of the New Sketch. 

Using the same options of drawing the polygon and circles that were used during preparing 

of Sketch1, draw and measure the geometry that it is presented in Fig. E6-4a, setting values of 

the diameters as 29 mm and 25 mm for the big and small circles, respectively.  

 

Sketch3 

The last part of the geometry which is placed in the same plane also has to be drawn in 

other sketch. Create therefore Sketch3 and draw four circles with diameter of 25 mm, that 

present the streams of hot liquid (Fig. E6-4b).  

    

Figure E6-4. View of the Sketch2 and Sketch3. 

When three sketches are ready you can go to the Modeling tab in order to create a 3D 

geometry. To do this use the Extrude tool three times, separately for each sketch. In the case of 

Sketch1 set up the Operation as Add Material, the Extent Type as Fixed and enter the FD1, 

Depth (>0) value as 400 mm. Generate the operation. 



In the case of Sketch2 and Sketch3 set up the same Extent Type and value of depth, however 

select the Add Frozen option from the Operation dropdown list (Fig. E6-5). By using this 

option, the extruded geometry will not connect with the second one even if they stay in direct 

contact. Therefore, for such part of the geometry it is possible to define a separate boundary 

conditions, different materials, etc. Please note that 

3D geometries which are not connected into one 

body (do not represent the same stream of the fluid) 

are marked with different colours (Fig. E6-6). Also, 

the default setup for Add Frozen geometries is that 

they are semi-transparent (Fig. E6-6a). This setup 

and also other options connected with body 

displaying can be changed (Fig. E6-6b) in main 

menu View.  Figure E6-5. Details of the Extrude option of Sketch2.  

   

Figure E6-6. Geometry generated using Extrude option with enabled Add Material and Add Frozen Operation.  

In the last step of preparing the geometry you have to add two sections of the pipeline that 

represents both inlet and outlet of the cold stream. To do this use Primitives → Cylinder twice, 

settings the values of variables available in the Details View windows presented in Fig. E6-7. 

Remember that cylinders are created in different plane comparing to the sketches. Please note 

that in the Details View window, except the Base Plane and type of the Operation, you can 

change also two types of values: below the Origin Definition, that are used to change the 

position of the geometry in the work space, and below the Axis Definition, that are used to set 

up the proper dimension of the geometry. In this example we will use both this options. 

Although the Problem Description says the distance from the axis of the horizontal pipe to the 

end of the vertical pipe is equal 0.09 m, we cannot create the cylinder placed directly at the axis 

with length of 0.09 m. It is because the new cylinders cannot intersect the prepared earlier 



geometries of hot streams and solid body. Therefore, a combination of Origin Definition and 

Axis Definition is necessary. Here we draw two cylinders with length of 0.04 m that are moved 

along Z axis by a distance 0.05 m and -0.09 for Cylinder1 and Cylinder2, respectively.  

  

Figure E6-7. Details of Cylinder1 and Cylinder2. 

Note, that we used one of the possible way to draw the geometry of the flow domain. In 

fact, the same geometry can be drawn much faster only using the Primitives and a combination 

of operations such as Add Material, Add Frozen, Cut Material or Slice Material.  

In the Tree Outline you can find now 9 Parts, 9 Bodies (Fig. E6-8a). With LMB and 

pressing the Ctrl button select from the tree four bodies that represents tubes (they will be 

highlighted with yellow), click on them with RMB and select Form New Part option to connect 

them together (Fig. E6-8b). Then rename New Part as Tubes again by clicking on it with RMB 

and choosing Rename Bodies option. Do the same with bodies that represent hot stream and 

rename another new part as Hot. The remaining body rename as Cold. Now in the tree you can 

find 3 Parts, 9 Bodies (Fig. E6-8c). You can close Ansys DesignModeler.  

   

Figure E6-8. Steps in forming a New Part. 



6.4. Mesh 

Open the Ansys Meshing, rename the geometry as Heat_Exchanger, and set the Material 

as a Fluid for Cold and Hot bodies, and as a Solid for Tubes bodies. Next, choose the Mesh 

from the Outline Tree. Ensure that in the Details of “Mesh” the Physics Preference is set as 

CFD and Solver Preference as Fluent, and confirm by clicking Generate Mesh.  

Since the geometry contains three different parts – Cold, Tubes and Hot, we have to enter 

the proper mesh settings partially, step by step for each part.  

 

Mesh settings for the Cold part of the geometry   

In the Outline Tree click with RMB on the Tubes and select Hide Body option. Perform the 

same operation for Hot part. Now in the main window you can see only Cold part of the flow 

domain. Select Mesh from the Outline Tree. On the top ribbon new tabs will appear. Select the 

Mesh tab and choose the Inflation operation (Fig. E6-9). In the Details of “Inflation” – Inflation 

dialog box select as a Geometry the whole body (Fig. E6-10a), and as Boundary four cylindrical 

surfaces (Fig. E6-10b). Now from the Mesh tab select the Sizing operation. As the Geometry 

select two edges – circles that represent border of the shell (Fig. E6-10c). In the Details of 

“Edge Sizing” – Sizing dialog box select the Definition Type as Number of Divisions and enter 

the Number of Divisions as 120 (Fig. E6-10d). Again select the Sizing operation from the Mesh 

tab and select eight edges that represent outer border of the tubes as the Geometry (Fig. E6-

10e). Set the Definition Type as Number of Divisions entering 60 divisions (Fig. E6-10f). 

 

Figure E6-9. Inflation operation on the top ribbon. 
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Figure E6-10. Settings of the mesh for Cold part of the flow domain. 

Mesh settings for the Hot part of the geometry   

In the Outline Tree click with RMB on the Hot and select Show Body option. Click again 

on the Cold and select Hide Body option. Now in the main window you can see only Hot part 

of the flow domain. Select the Inflation operation. In the Details of “Inflation” – Inflation 

dialog box select as a Geometry four tubes and as Boundary four cylindrical surfaces (Fig. E6-

11a). Now select the Sizing operation. As the Geometry select eight edges that represent inner 

border of the tubes (Fig. E6-11b). Enter the Number of Divisions as 32. 

a) b) 

  

Figure E6-11. Settings of the mesh for Hot part of the flow domain. 



Mesh settings for the Tubes part of the geometry   

In the Outline Tree click with RMB on the Tubes and select Show Body option. Click again 

on the Hot and select Hide Body option. Now in the main window you can see only Tubes part 

of the flow domain. Select the Sizing operation. As the Geometry select 16 edges that represent 

both outer and inner border of the tubes. Enter the Number of Divisions as 30 (Fig. E6-12a). 

Now from the Mesh tab select the Face Meshing operation. As the Geometry select from the 

Tubes 8 annular faces and enter the Internal Number of Divisions as 3 (Fig. E6-12b). 

a) b) 

  

Figure E6-12. Settings of the mesh for Tubes part of the flow domain. 

 

When the above settings are entered you can 

show all bodies in the main window and click 

Generate button in order to generate the mesh. As 

a result, you should obtain the mesh with two layers 

of regular cells that are located around the tubes 

wall (Fig. E6-13). Please note that the cell size 

inside the tubes is still quite big. Nevertheless, due 

to the limitation described earlier we are not able to 

increase the total number of cell. 

Figure E6-13. The resultant mesh. 

 

In the last step create seven Named Selections – Hot_inlet and Hot_outlet (both of them 

contain four surfaces), Cold_inlet and Cold_outlet, Wall, Tubes_outside and Tubes_inside (both 

of them contain four surfaces). They are presented in Fig. E6-14. Note that in this flow problem 

the necessary Named Selections are inlets and outlets only. Nevertheless the remaining Named 

Selections are needed in the case when we want to generate the results directly on the surfaces 

they represent.  

 



 

 

 

 

Figure E6-14. Named Selections.  



6.5. Simulations 

Open the Ansys Fluent with enabled Double Precision and Display Mesh After Reading 

options and set the Solver Processes as 1. Run down the Outline View Tree to edit subsequent 

parameters and variables: 

 

A. Setup – General 

Examine the following settings: Mesh → Check, Mesh → Report Quality, Solver Type → 

Pressure-Based, Solver Velocity Formulation → Absolute, Time → Steady.  

 

B. Setup – Models 

From the Models Task Page select the Energy equation and the Viscous → k-epsilon (2 

eqn) model, since the water flow in shell and tubes of the heat exchanger is turbulent. Use the 

default Standard from the k-epsilon Model group and choose Enhanced Wall Treatment from 

the Near-Wall Treatment. Do not change the values of Model Constants. Click OK to accept 

the model settings and close the Viscous Model dialog box. 

 

C. Setup – Materials 

Open the Materials Task Page and add water-liquid (h2o<l>) to the to the Fluid Materials 

list. In this example, however, we will use as material not only a fluid, but also solid that 

represents the tubes. The default solid material is aluminum, 

while the tubes in this example are made of copper (see 

problem description). Therefore, we must add also the copper 

to the Solid Materials list. It can be done analogically as in the 

case of fluid material adding – when the Solid filed in the 

Materials Task Page is highlighted click on the Create/Edit… 

to open new dialog box (Fig. E6-15a). Make sure that the 

Material Type is set up as solid (Fig. E6-15b) and then from the 

Fluent Database select copper (Fig. E6-15c). Click Copy and 

Close. 

 

 

 

Figure E6-15. Steps of 

adding the solid material.   



D. Setup – Cell Zone Conditions 

Open the Cell Zone Conditions Task Page and select the water-liquid as a process fluid 

that flows in the cold and hot zones. Then open the tubes zone and here set the material as 

copper. Confirm your choice by clicking Apply. 

 

E. Setup – Boundary Conditions 

Open the Boundary Conditions Task Page and set the following boundary conditions: 

1. cold_inlet: Type → velocity-inlet, Momentum tab - Velocity Magnitude [m/s] → 0.5, 

Thermal tab -  Temperature [K] → 283, 

2. cold_outlet: Type → outflow, 

3. hot_inlet: Type → velocity-inlet, Momentum tab - Velocity Magnitude [m/s] → 0.1, 

Thermal tab -  Temperature [K] → 353, 

4. cold_outlet: Type → outflow. 

 

F. Solution – Methods 

Open the Solution Methods Task Page and ensure that the options within this page are set 

up as: Scheme → Coupled, Flux Type → Auto Select, Gradient → Least Squares Cell Based, 

Pressure → Second Order, Momentum, Turbulent Kinetic Energy, k, Turbulent Dissipation 

Rate, ε, and Energy → Second Order Upwind, and other options are disabled.  

 

G. Solution – Monitors 

Open the Residual Monitors dialog box, make sure that all equations are monitored and 

their convergence is checked. Then set all Absolute Criteria as 1e-7.  

 

H. Solution – Initialization 

Open the Solution Initialization Task Page and initialize the calculation selecting the 

Hybrid Initialization. 

 

I. Solution – Run Calculation 

Open the Run Calculation Task Page and examine your setup selecting Check Case… You 

should see the recommendation to consider realizable k-epsilon turbulence model, nevertheless 

do not apply this model and close the dialog box. You can start the calculation by entering 1000 

iterations. During the calculations in the main window you will observe the Scaled Residuals. 

 



6.6. Results 

The contours of the fluid static temperature are presented in two mid-planes of the heat 

exchanger, located along the ZX (Figs. E6-16a and b) and ZY planes (Figs. E6-16c). The mid-

planes had to be created before data reading. Figs. E6-16a and E6-16c show the full range of 

static temperature, while in Fig. E6-16b the temperature range has been limited in order to better 

visualize the temperature change inside the tubes. If we need to display a narrowed range of the 

analysed property, it can be done by disabling the Auto Range option in the Contours dialog 

box (Fig. E6-17). Then the fields with the minimum and maximum value of the analysed 

property become active, so we can easily define them. 

a)  

b)  

c)  

Figure E6-16. Contours of fluid velocity magnitude and temperature in the mid-plane and at the outflow. 



 

Figure E6-17. Contours dialog box with enabled Auto Range option. 

The mean value of the static temperature at the inlets and outlets were read in the same way 

as in the Example 5, using the Reports tab and Surface Integrals option. Obtained values of the 

static temperature are presented in Fig. E6-18. 

 

Figure E6-18. Average value of temperature at the outflow. 


