
Example 3. Modelling of Taylor-Couette Flow for a Newtonian Fluid 

3.1. Introduction and Objectives 

The viscosity-induced fluid flow that occurs between two parallel walls while one of them 

is moving and the other remains stationary is called Couette flow. Couette flow can also occur 

in more complex geometries, for example between two coaxial cylinders. It is important which 

cylinder is rotating. If the outer, laminar flow is much more stable. The high rotational 

frequency of the inner cylinder can disturb the laminar fluid flow by the acting centrifugal force. 

Increasing the rotational speed of the inner cylinder leads to an increase in centrifugal forces 

that overcome the viscous forces between the liquid particles. This causes the formation of 

toroidal vortices in the space between two cylinders called Taylor vortices. The fluid flow is 

then called the Taylor-Couette flow, which will be the object of our interest in this example. 

The main objectives of this exercise are as follows: 

 create 3D geometry of the flow domain from 2D sketch using Extrude option, 

 illustrate the setup of the simulation with wall in motion – employing the Rotating Wall 

boundary condition, 

 visualization of results – contours of axial and radial components of fluid velocity. 

 

3.2. Problem Description 

Details of the analysed flow problem are shown in Figure E3-1. 

 

Figure E3-1. Problem description.  
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3.3. Geometry 

Open Ansys DesignModeler in order to draw 

the geometry of the flow domain. In this example, 

we will first draw a two-dimensional sketch, which 

will be then extruded to create a three-dimensional 

object. In this purpose change the Tree Outline that 

is used to display and edit all operations done with 

3D objects for the Sketching Toolboxes that are 

used to draw 2D sketches. This can be done by 

pressing the Sketching tab (Fig. E3-2). 

Figure E3-2. Sketching Toolboxes.  

Before we start drawing our geometry, we should setup a proper view. The proper view 

means a view that is perpendicular to the plane at which we want to draw (an active plane). The 

default active plane is always XYPlane and the default view is always an isometric view. In 

order to setup a perpendicular view click the Look At Face/Plane/Sketch icon that is visible in 

the main menu (Fig. E3-3). When the view is proper, you can come back to the Sketching 

Toolboxes, where you can find different tabs, such as Draw, Modify, Dimensions, Constraints 

and Settings (Fig. E3-3). 

 

Figure E3-3. Basic view on the DesignModeler window with enabled Sketching tab.  

 

In the first step of drawing make sure that Auto Constraints options are enabled (Fig. E3-

4). It is important since they allow new sketch entities to automatically snap to a particular 



location or orientation. Choose Sketching 

Toolboxes → Constraints → Auto Constraints and 

if they are disabled select both, Global and Cursor 

options. 

Now go to the Draw tab and select Circle. 

Move the cursor to the Graphics window and click 

the point where two axes intersect (the origin of the 

coordinate system). Make sure you started drawing   Figure E3-4. Auto Constraints.  

exactly at this point – this will be indicated by subtle “P” letter near the junction of the axes. 

Move the cursor away from the centre (but still in the field of Graphics window) and click again 

to finish drawing the geometry (Fig. E3-5a). Do not bother with the dimension of the circle now 

– we will set all the dimensions in the next step. Now draw the second, larger circle in the same 

way (Fig. E3-5b). 

   

Figure E3-5. The circles drawn in the Graphics window. 

Now set up the dimensions of the circles. In this purpose open the Dimensions tab and 

select the General option that allows you to measure the diameter of the circles. In order to 

measure the diameter of the larger circle click on the edge of this circle, move the cursor away 

but still in the field of Graphics window 

and click again. The dimension D1 was 

added in the sketch as well as in the 

Details view window. In the same way 

measure the smaller circle (D2). Now in 

the Details view window enter the proper 

dimensions of the circles – D1 = 1 m and 

D2 = 0.8 m (Fig. E3-6). 

 

Figure E3-6. The circles dimensioning. 



After dimensioning, the sketch is complete and can be converted to 3D geometry. To do 

this, go back to the Modeling tab. You can change the view for the isometric one by clicking 

on the blue sphere near the coordinate system visible in the right bottom corner (Fig. E3-7a). 

When you unfold the XYPlane in Tree Outline and select Sketch1, the sketch view is highlighted 

in yellow in the Graphics window. This option is not so important here, but it will be very 

important for more complex geometries that are drawn in several sketches. When the Sketch1 

is selected choose form the top ribbon the Extrude (Fig. E3-7b). In the Details View window 

(Fig. E3-7c), you can set the parameters of Extrude option. First click Apply to choose the 

Sketch1 as a geometry to be extruded. Then enter the FD1, Depth (>0) as 2 m. After entering 

these options in the Graphics window you will see a grey wireframe of the geometry to be 

extruded (Fig. E3-7d). In order to generate the geometry, you have to confirm the operation by 

clicking Generate button. If everything was done correctly, you will see a grey 3D geometry in 

the Graphics window (Fig. E3-7e). You can close Ansys DesignModeler. 

 

a) c) 

 

 

b) 

 

d) e) 

  

Figure E3-7. Steps of the 3D geometry creating from the 2D sketch. 



3.4. Mesh 

Open the Ansys Meshing, rename the geometry as Cylinder, and set up the Material as 

Fluid. Next, choose the Mesh from the Tree Outline. Ensure that in the Details of “Mesh” the 

Physics Preference is set as CFD and Solver Preference as Fluent, and confirm by clicking 

Generate Mesh. The grid is now coarse, therefore from the Top Menu select the Mesh tab and 

the Sizing option in order to improve the grid. Details of “Sizing” – Sizing window will appear 

under the Outline Tree with several options to set up. Firstly, you need to define the Geometry 

(highlighted with yellow background). In this purpose from the Graphics Toolbar select the 

Edge option that allows you to select particular edges directly from the geometry. Press and 

hold the Ctrl button from the keyboard and select four circular edges from the cylindrical 

geometry of flow domain. When four edges are selected then click once on the No selection 

next to the Geometry in the Details of “Sizing” – Sizing box. No selection will change for 

Apply/Cancel. Confirm your choice by Apply. Next change the Type for the Number of 

Divisions and enter the Number of Divisions as 180. Yellow markers appear on the geometry to 

show 180 equal segments. Regenerate the mesh and examine its Quality and Statistics. The 

subsequent steps of mesh generation are presented in Fig. E3-8. 

 

 

Figure E3-8. Steps of the mesh generation.   



In the next step create the Named Selections giving them the following names (Fig. E3-9): 

1. outer cylindrical surface – stator, 

2. inner cylindrical surface – rotor,  

3. bottom annular surface – inlet, 

4. top annular surface – outlet. 

 

Figure E3-9. Named Selection.  

Save the project and close Ansys Meshing. 

 

3.5. Simulations 

In order to perform numerical simulations, open the Ansys Fluent. Ensure that Display 

Mesh After Reading option is enabled and the Solver Processes is set up as 1. Run down the 

Outline View Tree to edit subsequent parameters and variables: 

 

A. Setup – General 

1. Mesh → Check, 

2. Mesh → Report Quality, 

3. Units → ensure that the unit of the angular 

velocity is set up as rad/s (Fig. E3-10),    

4. Solver Type → Pressure-Based, 

5. Solver Velocity Formulation → Absolute,  Figure E3-10. Units settings dialog box. 

6. Time → Steady.  



B. Setup – Models 

Select the Viscous → Laminar model from the Models Task Page.  

 

C. Setup – Materials 

Open the Materials Task Page and add water-liquid (h2o<l>) to the to the Materials lists. 

 

D. Setup – Cell Zone Conditions 

Open the Cell Zone Conditions Task Page and select the water-liquid as a process fluid 

that flows in the annular zone (named as cylinder). 

 

E. Setup – Boundary Conditions 

Open the Boundary Conditions Task Page and firstly set up the boundary conditions as the 

Wall for the stator and rotor, the interior for the interior-cylinder zone, the outflow for the 

outlet zone and the velocity-inlet for the inlet zone.  

In this case, we will not define the velocity of the fluid at the inlet zone, since the rotating 

inner cylinder is the only factor that drives the flow. Therefore, things we have to change are 

the settings of the rotor. 

In this purpose select the rotor from the Zone list and press Edit…. A new Wall dialog box 

will open. Set up the following parameters as (Fig. E3-11): 

1. Wall Motion → Moving Wall,  

2. Motion → Relative to Adjacent Cell Zone,  

3. Motion → Rotational, 

4. Speed [rad/s] → enter the value 0.02 [rad/s] 

(make sure that before entering value you 

already changed the type of motion from 

the default Translational for Rotational), 

Figure E3-11. Moving Wall dialog box. 

5. Shear Condition → No Slip. 

After entering the above setup confirm it by clicking Apply and close the window. Note 

that in the Wall dialog box there is also a possibility to define the Rotation-Axis Origin and 

Direction (Fig. E3-11). If you draw the flow domain geometry exactly like in this tutorial, left 

these values without change. But if the origin of the rotation axis and/or the rotation axis 

direction in your geometry are different, you have to enter the proper values here in order to 

correctly represent the rotation of the computational domain.  



F. Solution – Methods 

Open the Solution Methods Task Page and ensure that the options within this page are set 

up as: Scheme → Coupled, Flux Type → Auto Select, Gradient → Least Squares Cell Based, 

Pressure → Second Order, Momentum → Second Order Upwind, and other options are 

disabled.  

 

G. Solution – Monitors 

Open the Residual Monitors dialog box, make sure that all equations are monitored and 

their convergence is checked. Then set all Absolute Criteria as 1e-7.  

 

H. Solution – Initialization 

Open the Solution Initialization Task Page and initialize the calculation selecting the 

Standard Initialization with enabled Compute from all-zones option. 

 

I. Solution – Run Calculation 

Open the Run Calculation Task Page and examine your setup selecting Check Case… You 

should see the recommendation about flow specification at the inlet boundary. Nevertheless, as 

it was explained, left the default 0 [m/s] value. If there are no other recommendations, you can 

start the calculation by entering 350 iterations. During the calculations in the main window you 

will observe the Scaled Residuals (Fig. E3-12) that do not fall as much as in Examples 1 and 2 

without moving parts.  

 

Figure E3-12. Residuals for the converged solution. 



3.6. Results 

In this example results will be presented as a contours of the axial and radial fluid velocity 

components on the rotor surface and in the gap between the inner and outer cylinders (rotor and 

stator). The rotor surface is available on the Surfaces lists of Contours dialog box, but surface 

representing the gap between two cylinders (a vertical mid-plane of the flow domain) have to 

be created. To do this examine section 1.6 (Example 1).  

To create contours of the axial components of 

fluid velocity open the Contours dialog box and 

enter the following settings (E3-13): 

1. Contours of → Velocity… → Axial 

Velocity, 

2. Surfaces → select rotor and new plane that 

you created, here it is plane-4, 

3. Coloring → Smooth, 

4. Options such as Filled, Node Values, 

Global Range and Auto Range should be 

enabled.  Figure E3-13. Contours dialog box. 

Click Save/Display button. After checking the results create similar one by choosing the Radial 

Velocity from the dropdown list. The results are presented in Figure E3-14. 

    

Figure E3-14. Contours of axial and radial velocity components. 


