
Example 1. Modelling of Laminar Flow of Newtonian Fluid in a Pipe 

1.1. Introduction and Objectives 

A flow that is completely bounded by a solid surface is called an internal flow. Internal 

flows are widespread in all industries as they involve many important and practical flows such 

as flow through pipelines and accompanying fittings. Depending on value of the Reynolds 

number, internal flows can be laminar, transitional or turbulent. In this simple example we will 

consider the laminar flow (Re = 500) of a Newtonian fluid (water) through a pipe with a smooth 

surface. The main objectives of this exercise are as follows: 

 draw 3D geometry of the flow domain using Primitives options, 

 generate a structured mesh, 

 identify and create Named Selection – individual parts of flow domain to which different 

materials or boundary conditions will be assign, 

 illustrate the setup of the laminar fluid flow simulation, 

 visualization of results – contours and profiles of fluid velocity. 

 

1.2. Problem Description 

Details of the analysed flow problem are shown in Figure E1-1. 

 

 

Figure E1-1. Problem description. 
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1.3. Simulations 

Open the Ansys Fluent software by a double-

click the Setup in the Fluent module. During the 

first start of Ansys Fluent, the Fluent Launcher 

(Fig. E1-2) will open, where the user can check and 

set a several start-up options. Enter the Double 

Precision, Display Mesh After Reading and Solver 

Processes equal to 1. Then click Start in order to 

launch Ansys Fluent. Import the mesh available on 

adylak.zut.edu.pl. 

 

 

Figure E1-2. Fluent Launcher. 

The Ansys Fluent window (Fig. E1-3) is segmented into several menus. On the top ribbon 

we can find various tabs, e.g. File, Domain, Physics, Solution, etc., where all adjusting 

properties are collected. Below the top ribbon there is an Outline View that include each step of 

setting up the simulation, a Task Page where we can enter the variables and properties available 

in each step of the Outline Tree, and the main window where we can observe the domain, 

simulation progress or results. There is also a Console under the main window – a command 

line that shows the progress of simulation or errors. Here, the user can also enter specific 

commands to perform particular tasks.  

 

Figure E1-3. Ansys Fluent layout. 



Operating the Ansys Fluent will mainly consist of running down the tree in Outline View 

and editing parameters and variables in each respective Task Page. 

A. Setup – General 

From the General Task Page (Fig. E1-4) choose the following options:  

 

1. Mesh → Check – program will report the 

results of the mesh check in the console. 

Make sure that the minimum volume is not 

negative as the calculation cannot begin in 

this case. 

2. Mesh → Report Quality – program will 

report the results of the mesh quality in the 

console. Values of cell orthogonality can 

vary between 0 and 1, where 0 correspond 

to a very poor cell quality. In general, the 

minimum orthogonality should not be 

below 0.01 with the average value 

significantly larger.  

Figure E1-4. General Task Page. 

3. Solver Type → Pressure-Based – proper for low-speed incompressible to high-speed 

compressible flows. 

4. Solver Velocity Formulation → Absolute – proper for cases where majority of the 

domain is non-rotational. 

5. Time → Steady – for a steady-state solution.  

 

B. Setup – Models 

The purpose of this flow task is to simulate the 

laminar flow of a liquid, therefore only Viscous → 

Laminar should be selected from the list of 

available models. Open the Models Task Page (Fig. 

E1-5) by double-click the Models in the Outline 

View Tree. Make sure that the Laminar model is 

selected within the Viscous tab.  

Figure E1-5. Models Task Page. 



C. Setup – Materials 

Open the Materials Task Page (Fig. E1-6) by double-click the Materials in the Outline 

View Tree. Default materials are air as a fluid and aluminum as solid. The presented simulation 

is performed for the water therefore it is necessary to create this material. In this purpose click 

Create/Edit… button visible at the bottom of the 

Materials Task Page that launch a new window – 

Create/Edit Materials (Fig. E1-7a). Water is a 

material that is available in the Ansys Fluent 

Database. Click on the Fluent Database… on the 

right. In the new window (Fluent Database 

Materials, Fig. E1-7b) find in the list the water-

liquid (h2o<l>). Select this material and confirm 

with Copy. Material was automatically added to the 

Materials lists on the Materials Task Page. You 

can close both Fluent Database Materials and 

Create/Edit Materials windows. 

Figure E1-6. Materials Task Page. 

 

Figure E1-7. Adding a new material from the Fluent Database. 

 

D. Setup – Cell Zone Conditions 

Open the Cell Zone Conditions Task Page (Fig. E1-8a) by double-click the Cell Zone 

Conditions in the Outline View Tree. From the Zone list select pipe and click Edit…. In a new 

Fluid window (Fig. E1-8b) the default material is the air. Change the Material Name for the 

water-liquid by selecting it from the dropdown list and confirm with Apply button. The rest 

setting left without change and close the Fluid window.  



 

Figure E1-8. Setup of the Cell Zone Conditions. 

 

E. Setup – Boundary Conditions 

Open the Boundary Conditions Task Page (Fig. E1-9a) by double-click the Boundary 

Conditions in the Outline View Tree. On the Zone list there are sections that were created in the 

Ansys Meshing, i.e. inlet, outlet and wall. Also, the interior-pipe zone was created 

automatically. For each Zone it is necessary to define a proper type of a boundary condition. 

From Zone list select the wall name and make sure that the type of boundary condition is set up 

as Wall (Fig. E1-9b). 

  

Figure E1-9. Boundary Condition Task Page and definition of the boundary condition type. 

 

With the same procedure set up the remaining boundary conditions as: 

1. for the interior-pipe zone → the interior boundary condition, 

2. for the outlet zone → the pressure-outlet boundary condition, 



3. for the inlet zone → the velocity-inlet boundary condition. We also need to enter the 

velocity of the fluid at the pipe entrance. In this purpose click Edit… and in the Velocity 

Inlet dialog box (Fig. E1-10) enter the Velocity Magnitude [m/s] as w = 0.001005 [m/s]. 

This value was calculated from the Reynolds number definition for the specified in the 

example values of the Reynolds number, pipe diameter and water properties (density 

and viscosity, Fig. E1-7). 

 

Figure E1-10. Velocity Inlet dialog box. 

 

F. Solution – Methods  

Open the Solution Methods Task Page (Fig. E1-11) by double-click the Methods in the 

Outline View Tree. Ensure that the options within 

this page are set up as: 

1. Scheme → Coupled, 

2. Flux Type → Auto Select,  

3. Gradient → Least Squares Cell Based,  

4. Pressure → Second Order,  

5. Momentum → Second Order Upwind, 

6. Other options are disabled. 

Figure E1-11. Solution Methods Task Page. 

G. Solution – Monitors 

Expand the Monitors tab in the Outline View Tree by clicking “plus” icon on the left side 

of this tab. Then open the Residual Monitors dialog box (Fig. E1-12) by double-click the 

Residual in the Outline View Tree. Make sure that all equations are monitored and their 

convergence is checked, as it is shown in the Fig. E1-12. Set all Absolute Criteria as 1e-13 and 

close the window by clicking OK.  



 

Figure E1-12. Residual Monitors dialog box. 

 

H. Solution – Initialization 

Open the Solution Initialization Task Page 

(Fig. E1-13a) by double-click the Initialization in 

the Outline View Tree. Here, the user can choose 

between two types of initialization: 

1. Hybrid Initialization – provides a quick 

approximation of the flow field by solving 

Laplace’s equation to estimate a flow and 

pressure fields. 

2. Standard Initialization – sets all mesh cells 

to a single starting value. The user should 

enter values of parameters that are close to 

the final solutions in order to help the 

solution converge faster. The options 

Compute from inlet takes inlet conditions 

that was defined in the boundary conditions 

tab and applies them to the whole mesh as 

a starting guess.  

In this example we use the Standard 

Initialization with enabled Compute from inlet 

option (Fig. E1-13b). After selecting the 

initialization technique, click Initialize button. 

Figure E1-13. Solution Initialization Task Page. 



I. Solution – Run Calculation 

Open the Run Calculation Task Page (Fig. E1-14) by double-click the Run Calculation in 

the Outline View Tree. Before run calculation press the Check Case… button to make sure 

everything was set up correctly. You should get the information “No recommendation to make 

at this time”, that means the setup is good.  

 

Set the Number of Iterations as 200 and click 

Calculate. During the calculations in the main 

window you will see the Scaled Residuals for each 

of the equation parameters (in this case continuity, 

x-velocity, y-velocity, z-velocity) as in Fig. E1-15. 

The solution will be stopped by Ansys Fluent when 

all residuals reach their specified values (here 1e-

13) or after 200 iterations. After complete the 

iteration you will see the dialog box with the 

information “Calculation complete”.  

Figure E1-14. Run Calculation Task Page. 

 

Figure E1-15. Residuals for the converged solution. 

 

Since the solution in the above example is convergent we can start displaying the results. 

It can be done in both Ansys Fluent and CFD Post programs. Here we will use the Ansys Fluent. 



1.4. Results 

In this example as a results we will show 

contours and profiles of fluid velocity. In order to 

create contours of velocity double-click the 

Contours in the Outline View Tree. A Contours 

dialog box will open (Fig. E1-16). The contours of 

velocity will be presented at three locations: at the 

inlet, outlet and in the mid-plane of the pipe. Two 

of them (inlet and outlet) are visible in the Contours 

dialog box Surfaces list. The mid-plane has to be 

created.  

Figure E1-16. Contours dialog box. 

In this purpose from the Contours dialog box choose New 

Surface → Plane… A Plane Surface dialog box will open. Here 

enter the following settings (Fig. E1-17):  

1. New Surface Name → mid-plane, 

2. Method → YZ Plane, 

3. X → 0, 

4. Surfaces → 1,  

and confirm by clicking Create. Note that during creation of 

the new plane its shaded view is visible in the main window.  

Figure E1-17. Contours dialog box. 

 

After complete this operation a new plane will appear on the Surfaces list. Come back to 

the Contours dialog box and enter the following settings: 

1. Contours of → Velocity… → Velocity Magnitude, 

2. Surfaces → mid-plane, 

3. Coloring → Smooth, 

4. Options such as Filled, Node Values, Boundary Values, Global Range and Auto Range 

should be enabled. 

Click Save/Display button. A created contours of magnitude velocity in a mid-plane will 

appear in the main window. You can set up the proper view using the Pointer toolbar (rotate, 

pan, zoom options) or by clicking directly on the axes visible in the right bottom corner of main 



window. In a similar way create contours of magnitude velocity at the inlet and outlet surfaces. 

All these results are presented in Fig. E1-18. 

 

Figure E1-18. Contours of fluid velocity magnitude in the mid-plane, at the inflow and outflow surfaces. 

In order to create profiles of velocity double-click the XY Plot in the Outline View Tree. 

A Solution XY Plot dialog box will open. The profiles of velocity will be presented along the 

diameter of the pipe at three locations starting from the inlet: 0.5 m, 2.5 m and 4.5 m. They 

have to be created by choosing New Surface → Line/Rake… A Line/Rake Surface dialog box 

will open. Here enter the following settings (Fig. E1-19a):   

1. New Surface Name → line-0.5, 

2. Type → Rake, 

3. Number of Points → 25, 

4. End Points →    x0 [m] = 0,    y0 [m] = -0.25,    z0 [m] = 0.5,  

      x1 [m] = 0,    y1 [m] = 0.25,     z1 [m] = 0.5, 

and confirm by clicking Create. In analogous way create two remaining lines with the settings 

showed in Figs. E1-19b, c.  

   

Figure E1-19. Settings of the three line locations needed to XY Plot creation. 

After complete this operation new lines will appear on the Surfaces list. Come back to the 

Solution XY Plot dialog box and enter the following settings (Fig. E1-20): 

1. Plot Direction → X = 0, Y = 1, Z = 0, 

Mid-plane: 

Inlet:                                Outlet: 



2. Y Axis Function → Velocity… → Velocity Magnitude, 

3. X Axis Function → Direction Vector, 

4. Surfaces → line-0.5, line-2.5, line-4.5 (in order to select multiple objects press and hold 

Ctrl while you click on them), 

5. Options such as Node Values, Position on X Axis should be enabled. 

Confirm by clicking Save/Plot and close the window. As a result, in the main window you will 

see the graph with profiles of velocity magnitude along the diameter in three subsequent 

locations (Fig. E1-21). 

 

Figure E1-20. Settings in the Solution XY Plot dialog box. 

 

 

Figure E1-21. Profiles of velocity magnitude along the pipe diameter in three locations. 

 

Do not close Fluent software. We will start second exercise from this point. 



Example 2. Modelling of Turbulent Flow of Newtonian Fluid in Pipe 

2.1. Introduction and Objectives 

In the previous example we said that internal flows are widespread in all industries and we 

analysed a simple laminar flow through a pipe. However, most flows encountered in 

engineering practice are turbulent. Turbulent flow, instead of laminar one, does not flow in 

parallel layers but is characterized by random, irregular (chaotic) and rapid movement of 

particles of the fluid and, consequently, a significant variation of the flow properties in space 

and time. One of the advantage of the turbulent flow is highly efficient mixing of the fluid. On 

the other hand, it is much more complex than the laminar flow, thus the equations derived for 

the laminar flow are not sufficient to describe its random nature. In the case of the turbulent 

flow problem, the system of equations is supplemented with so-called turbulence model. In this 

example we will consider the turbulent flow (Re = 10 000) of a Newtonian fluid (water) through 

a pipe with the same dimensions as in exercise 1. 

The main objectives of this exercise are as follows: 

 simulations for the existing geometry of the computational domain and numerical mesh, 

 illustrate the setup of the turbulent fluid flow simulation, 

 visualization of results – contours and profiles of fluid velocity, contours of properties 

connected with turbulence. 

 

2.2. Problem Description 

Details of the analysed flow problem are shown in Figure E2-1. 

 

 

Figure E2-1. Problem description. 

 

2.3. Geometry and Mesh 

Geometry and mesh representing the flow domain in this example are the same like in the 

previous example. Only value of the Reynolds number has changed. 
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2.4. Simulations 

In general, the flow task presented in this example is very similar to that analysed in the 

Example 1. The only difference is that previously we examined the laminar flow, while now 

we have the turbulent flow of the water in the pipe since the Reynolds number was increased 

from Re = 500 to Re = 10 000. From this reason most of the settings within the Ansys Fluent 

will not change and therefore they will not be repeated in details within this section. All the 

new settings will be described with details. 

 

A. Setup – Models 

Open the Models Task Page by double-click the Models in the Outline View Tree. Next 

double-click on Viscous model from the list of available models. A new dialog box will open, 

that call Viscous Model. For turbulent flow analysis 

there are several models that approximate the 

solution. In this example we will use the k-ε 

turbulence model. Select the k-epsilon (2 eqn) 

model from the model list in Viscous Model dialog 

box. The dialog box will expand showing a new 

options characteristic for chosen turbulence model 

(Fig. E2-2). Use the default Standard from the  

k-epsilon Model group and choose Enhanced Wall 

Treatment from the Near-Wall Treatment. Do not 

change the values of Model Constants. Click OK to 

accept the model settings and close the Viscous 

Model dialog box.                              

 

 Figure E2-2. Viscous Model dialog box with enabled 

k-epsilon model. 

 

 

B. Setup – Boundary Conditions 

Open the Boundary Conditions Task Page and set up the boundary conditions as the Wall 

for the outer cylindrical wall zone, the interior for the interior-pipe zone, the pressure-outlet 

for the outlet zone and the velocity-inlet for the inlet zone. For the last boundary condition enter 

the Velocity Magnitude [m/s] as w = 0.0201 [m/s]. 



C. Solution – Methods 

Open the Solution Methods Task Page and ensure that the options within this page are set 

up the same as in the previous example, i.e.: Scheme → Coupled, Flux Type → Auto Select, 

Gradient → Least Squares Cell Based, Pressure → Second Order, Momentum → Second Order 

Upwind, and other options are disabled. Note that comparing to the previous example, here also 

the Turbulent Kinetic Energy, k, and Turbulent Dissipation Rate, ε, are calculated. For both 

these parameters select from the dropdown list the Second Order Upwind scheme of spatial 

discretization. 

D. Solution – Monitors 

Open the Residual Monitors dialog box, make sure that all equations are monitored and 

their convergence is checked. Then set all Absolute Criteria as 1e-13. Note that except 

continuity and velocity components now we can find here also k and ε – parameters that come 

from the turbulence model.  

E. Solution – Initialization 

Open the Solution Initialization Task Page and initialize the calculation selecting the 

Standard Initialization with enabled Compute from inlet option. 

F. Solution – Run Calculation 

Open the Run Calculation Task Page and examine your setup selecting Check Case… You 

should see the Case Check dialog box with recommendation to consider the realizable k-epsilon 

turbulence model instead of standard one (Fig. E2-3). Nevertheless, the analysed flow problem 

is quite simple, without complex structures, rotation, separation or recirculation. Therefore, we 

do not apply this recommendation. If there are no other recommendations, you can click Close 

in the dialog box and start the calculation by entering 200 iterations. During the calculations in 

the main window you will see the Scaled Residuals for six equation parameters (Fig. E2-4). 

 

Figure E2-2. Case Check dialog box with recommendation. 



 

Figure E2-4. Residuals for the converged solution. 

  

2.5. Results 

In this example results will be presented as a contours and profiles of the fluid velocity as 

well as contours of the turbulent kinetic energy and turbulent dissipation rate.  

In order to present velocity contours (Fig. E2-5) and profiles (Fig. E2-6) use mid-plane and 

three lines generated previously. Compare these results with the results from the Example 1.  

Contours of the turbulent kinetic energy and turbulent dissipation rate were created in the 

same way as velocity contours with such difference that in the Contours dialog box the 

Turbulence… was selected instead of the Velocity… (Fig. E2-7). Next, from the dropdown list 

first the Turbulent Kinetic Energy (k), and then the Turbulent Dissipation Rate (epsilon) were 

selected. Results are presented in Figure E2-8. 

 

 

Figure E2-5. Contours of fluid velocity magnitude in the mid-plane, at the inflow and outflow surfaces. 

 

Mid-plane: 

Inlet:                                Outlet: 



 

Figure E2-6. Profiles of velocity magnitude along the pipe diameter in three locations. 

 

 

Figure E2-7. Contours dialog box set up for the contours of the turbulent kinetic energy. 

 

 

 

Figure E2-8. Contours of turbulent kinetic energy and turbulent dissipation rate in the pipe mid-plane. 


