
Example 1. Modelling of Laminar Flow of Newtonian Fluid in a Pipe 

1.1. Introduction and Objectives 

A flow that is completely bounded by a solid surface is called an internal flow. Internal 

flows are widespread in all industries as they involve many important and practical flows such 

as flow through pipelines and accompanying fittings. Depending on value of the Reynolds 

number, internal flows can be laminar, transitional or turbulent. In this simple example we will 

consider the laminar flow (Re = 500) of a Newtonian fluid (water) through a pipe with a smooth 

surface. The main objectives of this exercise are as follows: 

 draw 3D geometry of the flow domain using Primitives options, 

 generate a structured mesh, 

 identify and create Named Selection – individual parts of flow domain to which different 

materials or boundary conditions will be assign, 

 illustrate the setup of the laminar fluid flow simulation, 

 visualization of results – contours and profiles of fluid velocity. 

 

1.2. Problem Description 

Details of the analysed flow problem are shown in Figure E1-1. 

 

 

Figure E1-1. Problem description. 

 

1.3. Geometry 

Into the Project Schematic window insert a Fluid Flow (Fluent) module from Analysis 

Systems tab. Open the Ansys DesignModeler as described in the Introduction. There are 

different methods of the geometry drawing. In this example we will use the Primitives method. 

From the main menu choose Create → Primitives → Cylinder (Fig. E1-2a). A new figure 

(Cylinder1) appeared in the Tree Outline, and its details such as basic plane, origin or 

dimensions are visible in the Details View window placed below the Tree Outline (Fig. E1-2b). 

Also a grey wireframe of the figure is visible in the Graphics window (Fig. E1-2b). In the 
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Details View window enter the following parameter values: Axis Z Component – 5 m and Radius 

– 0.25 m (Fig. E1-2c). Important information – Ansys DesignModeler uses comas instead of 

dots. After entering these values, click the Generate button from the top menu (Fig. E1-2d). 

If everything has been done correctly, a shaded figure will appear in the Graphics window and 

a corresponding green check mark will appear next to the cylinder name in Tree Outline 

(Fig. E1-2e). At the end save the project by selecting from the main menu File → Save Project. 

You can close Ansys DesignModeler. 

a) b) 
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Figure E1-2. Steps of the geometry drawing. 



1.4. Mesh 

Open the Ansys Meshing as described in the Introduction. After opening you will see 

a geometry window with the shape of the geometry drawn in the Geometry module in the 

previous step (Fig. E1-3). Over this window there is a main menu as well as different toolbars 

used, among others, to establish and edit the mesh settings, set up the Named Selection or set 

up the view of the flow domain. On the left side there are also the Tree Outline and Details 

View. Tree Outline is the object tree that represents outline view of the whole project and 

provides access to object’s context menus. Details View, similar like in Ansys DesignModeler, 

contains details about each object in the Tree Outline.  

 

Figure E1-3. Ansys Meshing basic view. 

Before the mesh generation we will change the name of the geometry and specify the 

material. In this purpose in the Tree Outline expand the Geometry, select the Solid with the 

RMB and choose Rename option (Fig. E1-4a). Enter the “Pipe” name. Now, in the Details of 

“Pipe” select the Material as Fluid (Fig. E1-4b). Please note that both above settings can be 

done in Ansys Meshing or Ansys DesignModeler module. 

Now choose the Mesh from the Tree Outline. The shape of the flow domain in the present 

example is quite simple, therefore it is possible to generate a structured mesh. In the Details of 

“Mesh” select the Defaults → Physics Preference as CFD and Solver Preference as Fluent 

(Fig. E1-4c). The same as in the Ansys DesignModeler each operation has to be ended with 

generation, therefore press the Generate Mesh button that is visible in the top Home Menu. The 

mesh will generate automatically. In the Details of “Mesh” you can check its Quality and 

Statistics (Fig. E1-4d). Recall form the chapter 5.1.2. Mesh Quality that in the case of the 



hexahedral element the mesh is considered good for skewness value less than 0.8. Here, the 

maximum value of skewness does not exceed 0.38. However, the number of elements is quite 

low – 3968 elements. We will increase this number by expanding in the Details of “Mesh” the 

Sizing tab and changing the default value of Growth Rate from 1.2 for 1.02 (Fig. E1-4e). After 

regenerate the mesh, the number of element in the grid increases to 5888 and the maximum 

value of skewness does not exceed 0.36 (Fig. E1-4f).  
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Figure E1-4. Steps of the mesh generation. 



The last step in the Ansys Meshing software is creation of Named Selection. In the analysed 

flow task, we will create three Named Selections on the surfaces – one for the inlet, one for the 

outlet and one for the wall. First, choose Face option from the Graphics Toolbar (Fig. E1-5a) 

and then select a proper surface from the geometry by clicking on them in the Geometry 

Window. The chosen surface is highlighted by green colour (Fig. E1-5b). Click again on this 

surface with RMB and choose Create Named Selection… In the new window that will appear 

enter a name for the chosen surface, here it is Outlet (Fig. E1-5c). Repeat this step for two 

remaining surfaces – Inlet and Wall. If you need to move or turn your geometry, you can do 

this using options collected in the Graphics Toolbar, such as Rotate, Pan, Zoom, Box Zoom, 

Zoom To Fit. All created Named Selections are visible in the Tree Outline. An active Named 

Selection is highlighted with red colour in the Geometry Window (Fig. E1-5d) and its 

characteristics are collected in the Details window. Save the project and close Ansys Meshing. 
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Figure E1-5. Creation of the Named Selections. 



1.5. Simulations 

Open the Ansys Fluent software by a double-

click the Setup in the Fluid Flow (Fluent) module. 

During the first start of Ansys Fluent, the Fluent 

Launcher (Fig. E1-6) will open, where the user can 

check and set a several start-up options. Enter the 

Double Precision, Display Mesh After Reading and 

Solver Processes equal to 1. Then click Start in 

order to launch Ansys Fluent. 

 

 

Figure E1-6. Fluent Launcher. 

 

The Ansys Fluent window (Fig. E1-7) is segmented into several menus. On the top ribbon 

we can find various tabs, e.g. File, Domain, Physics, Solution, etc., where all adjusting 

properties are collected. Below the top ribbon there is an Outline View that include each step of 

setting up the simulation, a Task Page where we can enter the variables and properties available 

in each step of the Outline Tree, and the main window where we can observe the domain, 

simulation progress or results. There is also a Console under the main window – a command 

line that shows the progress of simulation or errors. Here, the user can also enter specific 

commands to perform particular tasks.  

 

Figure E1-7. Ansys Fluent layout. 



Operating the Ansys Fluent will mainly consist of running down the tree in Outline View 

and editing parameters and variables in each respective Task Page. 

A. Setup – General 

From the General Task Page (Fig. E1-8) choose the following options:  

 

1. Mesh → Check – program will report the 

results of the mesh check in the console. 

Make sure that the minimum volume is not 

negative as the calculation cannot begin in 

this case. 

2. Mesh → Report Quality – program will 

report the results of the mesh quality in the 

console. Values of cell orthogonality can 

vary between 0 and 1, where 0 correspond 

to a very poor cell quality. In general, the 

minimum orthogonality should not be 

below 0.01 with the average value 

significantly larger.  

Figure E1-8. General Task Page. 

3. Solver Type → Pressure-Based – proper for low-speed incompressible to high-speed 

compressible flows. 

4. Solver Velocity Formulation → Absolute – proper for cases where majority of the 

domain is non-rotational. 

5. Time → Steady – for a steady-state solution.  

 

B. Setup – Models 

The purpose of this flow task is to simulate the 

laminar flow of a liquid, therefore only Viscous → 

Laminar should be selected from the list of 

available models. Open the Models Task Page (Fig. 

E1-9) by double-click the Models in the Outline 

View Tree. Make sure that the Laminar model is 

selected within the Viscous tab.  

Figure E1-9. Models Task Page. 



C. Setup – Materials 

Open the Materials Task Page (Fig. E1-10) by double-click the Materials in the Outline 

View Tree. Default materials are air as a fluid and aluminum as solid. The presented simulation 

is performed for the water therefore it is necessary to create this material. In this purpose click 

Create/Edit… button visible at the bottom of the 

Materials Task Page that launch a new window – 

Create/Edit Materials (Fig. E1-11a). Water is a 

material that is available in the Ansys Fluent 

Database. Click on the Fluent Database… on the 

right. In the new window (Fluent Database 

Materials, Fig. E1-11b) find in the list the water-

liquid (h2o<l>). Select this material and confirm 

with Copy. Material was automatically added to the 

Materials lists on the Materials Task Page. You 

can close both Fluent Database Materials and 

Create/Edit Materials windows. 

Figure E1-10. Materials Task Page. 

 

Figure E1-11. Adding a new material from the Fluent Database. 

 

D. Setup – Cell Zone Conditions 

Open the Cell Zone Conditions Task Page (Fig. E1-12a) by double-click the Cell Zone 

Conditions in the Outline View Tree. From the Zone list select pipe and click Edit…. In a new 

Fluid window (Fig. E1-12b) the default material is the air. Change the Material Name for the 

water-liquid by selecting it from the dropdown list and confirm with Apply button. The rest 

setting left without change and close the Fluid window.  



 

Figure E1-12. Setup of the Cell Zone Conditions. 

 

E. Setup – Boundary Conditions 

Open the Boundary Conditions Task Page (Fig. E1-13a) by double-click the Boundary 

Conditions in the Outline View Tree. On the Zone list there are sections that were created in the 

Ansys Meshing, i.e. inlet, outlet and wall. Also, the interior-pipe zone was created 

automatically. For each Zone it is necessary to define a proper type of a boundary condition. 

From Zone list select the wall name and make sure that the type of boundary condition is set up 

as Wall (Fig. E1-13b). 

  

Figure E1-13. Boundary Condition Task Page and definition of the boundary condition type. 

 

With the same procedure set up the remaining boundary conditions as: 

1. for the interior-pipe zone → the interior boundary condition, 

2. for the outlet zone → the pressure-outlet boundary condition, 



3. for the inlet zone → the velocity-inlet boundary condition. We also need to enter the 

velocity of the fluid at the pipe entrance. In this purpose click Edit… and in the Velocity 

Inlet dialog box (Fig. E1-14) enter the Velocity Magnitude [m/s] as w = 0.001005 [m/s]. 

This value was calculated from the Reynolds number definition for the specified in the 

example values of the Reynolds number, pipe diameter and water properties (density 

and viscosity, Fig. E1-11). 

 

Figure E1-14. Velocity Inlet dialog box. 

 

F. Solution – Methods  

Open the Solution Methods Task Page (Fig. E1-15) by double-click the Methods in the 

Outline View Tree. Ensure that the options within 

this page are set up as: 

1. Scheme → Coupled, 

2. Flux Type → Auto Select,  

3. Gradient → Least Squares Cell Based,  

4. Pressure → Second Order,  

5. Momentum → Second Order Upwind, 

6. Other options are disabled. 

Figure E1-15. Solution Methods Task Page. 

G. Solution – Monitors 

Expand the Monitors tab in the Outline View Tree by clicking “plus” icon on the left side 

of this tab. Then open the Residual Monitors dialog box (Fig. E1-16) by double-click the 

Residual in the Outline View Tree. Make sure that all equations are monitored and their 

convergence is checked, as it is shown in the Fig. E1-16. Set all Absolute Criteria as 1e-13 and 

close the window by clicking OK.  



 

Figure E1-16. Residual Monitors dialog box. 

 

H. Solution – Initialization 

Open the Solution Initialization Task Page 

(Fig. E1-17a) by double-click the Initialization in 

the Outline View Tree. Here, the user can choose 

between two types of initialization: 

1. Hybrid Initialization – provides a quick 

approximation of the flow field by solving 

Laplace’s equation to estimate a flow and 

pressure fields. 

2. Standard Initialization – sets all mesh cells 

to a single starting value. The user should 

enter values of parameters that are close to 

the final solutions in order to help the 

solution converge faster. The options 

Compute from inlet takes inlet conditions 

that was defined in the boundary conditions 

tab and applies them to the whole mesh as 

a starting guess.  

In this example we use the Standard 

Initialization with enabled Compute from inlet 

option (Fig. E1-17b). After selecting the 

initialization technique, click Initialize button. 

Figure E1-17. Solution Initialization Task Page. 



I. Solution – Run Calculation 

Open the Run Calculation Task Page (Fig. E1-18) by double-click the Run Calculation in 

the Outline View Tree. Before run calculation press the Check Case… button to make sure 

everything was set up correctly. You should get the information “No recommendation to make 

at this time”, that means the setup is good.  

 

Set the Number of Iterations as 200 and click 

Calculate. During the calculations in the main 

window you will see the Scaled Residuals for each 

of the equation parameters (in this case continuity, 

x-velocity, y-velocity, z-velocity) as in Fig. E1-19. 

The solution will be stopped by Ansys Fluent when 

all residuals reach their specified values (here 1e-

13) or after 200 iterations. After complete the 

iteration you will see the dialog box with the 

information “Calculation complete”.  

Figure E1-18. Run Calculation Task Page. 

 

Figure E1-19. Residuals for the converged solution. 

 

Since the solution in the above example is convergent we can start displaying the results. 

It can be done in both Ansys Fluent and CFD Post programs. Here we will use the Ansys Fluent. 



1.6. Results 

In this example as a results we will show 

contours and profiles of fluid velocity. In order to 

create contours of velocity double-click the 

Contours in the Outline View Tree. A Contours 

dialog box will open (Fig. E1-20). The contours of 

velocity will be presented at three locations: at the 

inlet, outlet and in the mid-plane of the pipe. Two 

of them (inlet and outlet) are visible in the Contours 

dialog box Surfaces list. The mid-plane has to be 

created.  

Figure E1-20. Contours dialog box. 

In this purpose from the Contours dialog box choose New 

Surface → Plane… A Plane Surface dialog box will open. Here 

enter the following settings (Fig. E1-21):  

1. New Surface Name → mid-plane, 

2. Method → YZ Plane, 

3. X → 0, 

4. Surfaces → 1,  

and confirm by clicking Create. Note that during creation of 

the new plane its shaded view is visible in the main window.  

Figure E1-21. Contours dialog box. 

 

After complete this operation a new plane will appear on the Surfaces list. Come back to 

the Contours dialog box and enter the following settings: 

1. Contours of → Velocity… → Velocity Magnitude, 

2. Surfaces → mid-plane, 

3. Coloring → Smooth, 

4. Options such as Filled, Node Values, Boundary Values, Global Range and Auto Range 

should be enabled. 

Click Save/Display button. A created contours of magnitude velocity in a mid-plane will 

appear in the main window. You can set up the proper view using the Pointer toolbar (rotate, 

pan, zoom options) or by clicking directly on the axes visible in the right bottom corner of main 



window. In a similar way create contours of magnitude velocity at the inlet and outlet surfaces. 

All these results are presented in Fig. E1-22. 

 

Figure E1-22. Contours of fluid velocity magnitude in the mid-plane, at the inflow and outflow surfaces. 

In order to create profiles of velocity double-click the XY Plot in the Outline View Tree. 

A Solution XY Plot dialog box will open. The profiles of velocity will be presented along the 

diameter of the pipe at three locations starting from the inlet: 0.5 m, 2.5 m and 4.5 m. They 

have to be created by choosing New Surface → Line/Rake… A Line/Rake Surface dialog box 

will open. Here enter the following settings (Fig. E1-23a):   

1. New Surface Name → line-0.5, 

2. Type → Rake, 

3. Number of Points → 25, 

4. End Points →    x0 [m] = 0,    y0 [m] = -0.25,    z0 [m] = 0.5,  

      x1 [m] = 0,    y1 [m] = 0.25,     z1 [m] = 0.5, 

and confirm by clicking Create. In analogous way create two remaining lines with the settings 

showed in Figs. E1-23b, c.  

   

Figure E1-23. Settings of the three line locations needed to XY Plot creation. 

After complete this operation new lines will appear on the Surfaces list. Come back to the 

Solution XY Plot dialog box and enter the following settings (Fig. E1-24): 

1. Plot Direction → X = 0, Y = 1, Z = 0, 

Mid-plane: 

Inlet:                                Outlet: 



2. Y Axis Function → Velocity… → Velocity Magnitude, 

3. X Axis Function → Direction Vector, 

4. Surfaces → line-0.5, line-2.5, line-4.5 (in order to select multiple objects press and hold 

Ctrl while you click on them), 

5. Options such as Node Values, Position on X Axis should be enabled. 

Confirm by clicking Save/Plot and close the window. As a result, in the main window you will 

see the graph with profiles of velocity magnitude along the diameter in three subsequent 

locations (Fig. E1-24). 

 

Figure E1-23. Settings in the Solution XY Plot dialog box. 

 

 

Figure E1-24. Profiles of velocity magnitude along the pipe diameter in three locations. 

 


